Mastodon アップデートの yarn install で node-sass がエラーになる

状況と解決方法

リリースノート の Upgrade notes に従って bundle install と yarn install を実行した際に以下のようなエラーが。

#error "_LIBCPP_TRIVIAL_PAIR_COPY_CTOR" is no longer supported.

調べてみると node のバージョンが問題のようです。
node 8.x が入っていたのですが、とりあえず node 6.x にしてみます。

pkg install node6
pkg install npm3

もう一度 yarn install をしたところうまくインストールされました。

この問題は node-sass プロジェクトで認識されていますが、node 9.x 対応の形でサポートするようなのでとりあえずこれで様子を見ます。

Can't compile node-sass on FreeBSD 11.1: "_LIBCPP_TRIVIAL_PAIR_COPY_CTOR" is no longer supported. #2153

Mastodon アカウント紹介

私の Mastodon アカウントはこちらですので宜しければフォローして下さい。

カテゴリ: 

ホビー・フィギュア通販