AtomマシンにFreeBSD7.0を導入

うちのメインサーバが常時メモリ不足でどきどきものなので、 サーバ移行を考えて試しに Atom マシンを組んでみました。 しかしこの常時メモリ不足の中しれっと動いてるのは凄い。

ちなみに組んだというか正確にはベアボーンです。
Shuttle X27 に 2GB のメモリと 160GB の2.5吋 HDD を搭載。
こんなかんじ。
X27/Macro

最初は ESXi でも動かしてディスクレスにしようかと思ったんですが、 Marvell な NIC では動かないようなので断念。
NS4300N に TFTP を入れて PXE boot も考えましたが、 全部 NFS に乗ってるのはどうかなーというのと思ったより TFTP 入れるのがだるそうなのでパス(笑)

そんなわけでさくさくインストール。 FreeBSD7.0 ではこいつが使っている NIC はすでにサポートされていたので、 このへん から bootonly な ISO ファイルを落としてきて焼き焼き。 あー今回は i386 を入れています。amd64 の恩恵は受けなさそうですし。
スリムタイプの CD/DVD ドライブはつけていないので、 ケースのふたを開けて適当な ATAPI の DVD ドライブをつないでそこからインストールしました。
さくっとネットワークにつながってネットワークインストールも完了。 これからいろいろ設定します。

まず gcc の最適化オプションに関する設定。
実際どのくらい影響があるのか分かりませんが、 最近の CPU も対応しているので以下のように設定。

echo CPUTYPE=core2 >> /etc/make.conf

/usr/share/mk/bsd.cpu.mk を見ると、 prescott として動くようです。SSE3 を使うとかかな。

ところで気づくと ACPI のエラーっぽいのが定期的に出てました。
make world したら消えるかなーと思いましたが 7.1-PRERELEASE にしても残念ながら消えず。

ACPI Error (psargs-0459): [\\_SB_.PCI0.SBUS.SRDB] Namespace lookup failure, AE_NOT_FOUND
ACPI Error (psparse-0626): Method parse/execution failed [\\RTMP] (Node 0xc4de85e0), AE_NOT_FOUND
ACPI Error (psparse-0626): Method parse/execution failed [\\_TZ_.THRM._TMP] (Node 0xc4de83a0), AE_NOT_FOUND

どうも温度が取れないということのようです。
温度は取れた方がうれしいのですが、 ずいぶん頻繁にログが出るのも気持ちよくないのでとりあえず以下のようにして出ないようにしました。

echo hw.acpi.thermal.polling_rate=0 >> /etc/sysctl.conf

再起動すると有効になります。 すぐ適用したいなら直接設定しちゃいましょう。

sysctl hw.acpi.thermal.polling_rate=0

これでポーリングしなくなりますが、 起動時の最初に取得しようとするようで失敗ログが残ることがあります。

あとこれは Atom マシンに限ったことではありませんが忘れていたのでメモ。
FreeBSD 上の apache で accf_http を使用する場合の設定。

/boot/loader.conf に以下を追加する。

accf_http_load="YES"

/etc/rc.conf に以下を追加する。

apache22_http_accept_enable="YES"

まだ試していませんが、 FreeBSD6.3 マシンもそうなっていますのでこれでいいようです。

引き続きちまちま進めていきたいと思います。 環境移行やテストが終わったら www.randomsoft.com もこの Atom マシンに移行したい。

カテゴリ: 

コメント

初めまして。
X27D+FreeBSDでACPI Errorが出る問題の解決策を探していたら
ここにたどり着きました。おかげさまで無事解決しました。
どうもありがとうございました。

X27D でも同様のエラーが出るんですね。
参考になって何よりです。
わざわざコメントいただきありがとうございました!


ホビー・フィギュア通販